
Exercício 4 – QGIS 3 

 

Operações geográficas: Coletar, Buffer, Agrega e Interseção. 

 

Parte I – Coletar e Buffer 

 

Abrir o Projeto das aulas anteriores 

Ativar os layers do Metrô, da CPTM e dos Distritos (sem erro geométrico) 

 MetroSP 

 CPTM 

 CEMDistMSP 

 

Contar quantas estações do Metrô há em cada Distrito 

Trata-se da mesma operação que havia sido feita para o caso dos homicides – exercício 
extra classe. 

 

Determinar, quais estações da CPTM se encontram a até 1000 m de uma estação 

do Metrô 

Criar um círculo de raio 1000 m de cada estação do Metrô e a partir desses círculos 

selecionar as estações da CPTM que estejam dentro. 

 

 MetroSP 

 CPTM 

 



No menu suspenso, selecionar Vector > Geoprocessing Tools > Buffer 

Input layer: MetroSP [EPSG:5533] 

Ao lado do botão [...] há um outro botão que permite que cada estação 
do Metrô gere um arquivo de buffer em separado. 

[   ] Selected features only – é possível usar apenas as estações desejadas, 
segundo algum critério. No presente caso interessam todas (e não houve 
selecção prévia, por isso a opção deve estar inacessível). 

Distance: 1000 meters 

Segments: 32 – número de segmentos de reta em cada arco quadrante 

End cap style: Round – mas não faz diferença por se tratar da geração de um 
círculo. 

Join style: idem, pela mesma razão 

Miter limit: 2 - default 

[   ] Dissolve result – para a pergunta em questão tanto faz, pois basta estar a 
no máximo 1km de qualquer estação. Se for marcado, permite que cada círculo 
(buffer) carregue a informação tabular do elemento a partir do qual e foi 
gerado. 

Buffered: clicar no botão [...] ... 

selecionar Save to File... 

navegar até a pasta desejada e dar um nome ao arquivo de buffers, por 
exemplo: ate_1km_do_Metro 

 Open output file after nunning algorithm – para incluir os buffers no 
mapa 

[ Run ] 

 

Se o layer resultante no mapa aparecer com o nome Buffered, altere o nome para o 
que havia sido escolhido antes. 

Desloque o layer de buffers para que fique visível sob os layers das estações do Metrô 
e da CPTM. 

[   ] MetroSP – ao se desabilitar a visualização das estações do Metrô, usadas para 
gerar os buffers, pode se ver que há estações da CPTM dentro deles. 

Se houvesse um grande número de buffers isolados, seria interessante criar indexação 
espacial para eles, mas, com apenas três polígonos acredita-se não ser necessário. 



Relembrando o que já foi feito em exercício anterior: 

selecionar Vector > Research Tools > Select by Location... 

para determiner quais as estações da CPTM estão dentro de uma das áreas de 
buffer, portanto a até 1 km de alguma estação do Metrô. 

Observe que: 

• A condição geométrica para a seleção é: are within (estar dentro) 

• ao lado do campo By comparing to fetaures from: até_1km_do_Metro 

existe um botão para, caso fosse necessário, criar arquivos separados para 
o conjunto de estações associada a cada buffer, mas não é este o caso. 

visualizar no mapa as estações da CPTM selecionadas 

e visualizar a tabela correspondente– estações da CPTM selecionadas, 
com o botão [ Show Selected Features ]: 

CORINTHIANS-ITAQUERA 
BRÁS 
BARRA FUNDA 
TATUAPE 
LUZ 
JULIO PRESTES 

 

Desfazer seleção das estações e Salvar o Projeto. 

 

  



Parte II - Agregação 

Nesta parte os municípios do Estado de São Paulo serão agregados (pela aglutinação 
de suas extensões territoriais) em suas microrregiões e estas em mesorregiões. 

Baixe e descompacte o arquivo: 

• SP_cities.zip – polígonos dos limites dos municípios do Estado de São Paulo 

Até o momento os exercícios realizados se restringiram à região Metropolitana de São 
Paulo. 

Agora a abrangência do estudo é o Estado de São Paulo, por isso há de se criar 
um novo Projeto. 

Crie o novo Projeto 

 

Importar municípios do Estado de São Paulo no âmbito do novo Projeto 

Adicione o layer vetorial SP_cities 
a partir do shapefile de mesmo nome 

As coordenadas de SP_cities são geográficas e estão referidas ao Datum SAD69. 
e devem ser corrigidas, pois, por não haver arquivo .prj no conjunto desse shapefile, o 
QGis deve ter assumido ser WGS84. 

SP_cities  Properties > Source 

Clique no botão [ k ] (globo) para selecionar 

SAD69(96) EPSG:5527 
da lista Geographic Coordinate Systems com SAD69... no campo Filter 

Observar que não se trata do SAD69(96) / UTM zone 23S usado anteriormente, 
por não haver projeção a definir – apenas os Data (plural de Datum) coincidem. 

Após sua seleção, clicar no botão [ Apply ] e [OK] antes de fechar a janela de 
propriedades. 



Exportar o layer referenciado corretamente para shapefile, mas, apar adiantar o que 
será feito na Parte III deste exercício, buscar e selecionar um novo sistema de 
coordenadas para o mesmo. 

SP_cities  Export > save features as... 

Format: ESRI Shapefile 

Filename: clique no botão […] navegue até a pasta desejada e indique um 
nome diferente para o shapefile, por exemplo: SP_citiesP 

CRS: SAD69(96) EPSG:5527 

[ OK ] 

Remover o layer original SP_cities, mantendo o novo SP_citiesG 

Verificar em properties do novo layer, se o SRC está correto e aproveitar para 
clicar no botão [ Create Spatial Index ] para indexar espacialmente os municípios. 

 

Alterar o SRC do Projeto também para o novo SRC definido e 

Salvar o Projeto 

Agregar municípios em suas respectivas microrregiões 

Abrir a tabela de dados dos municípios: 

SPRAREA: área de cada município (em m2 , ao que tudo indica) 
SPRPERIMET: perímetro (em m, ao que tudo indica) 
SPRROTULO: código IBGE 
SPRNOME: código IBGE (idem anterior) 
CODMUNIC: código IBGE (ibidem) 
COD: idem, mas sem o último dígito verificador 
NOMEMUNI: nome de cada município em maiúsculas e sem acentuação 
CODUF: código IBGE do Estado de São Paulo IBGE - como número ponto 
flutuante !? 
NOMEUF: SAO PAULO 
SIGLAUF: SP 
POPULACA: população 
POPHOMEN: população do sexo masculino 
POPMULHE: população do sexo feminino 
POPURBAN: população urbana 
POPRURAL: população rural 
REGIAO: SUDESTE 
CODMESO: código da mesorregião 
NOMEMESO: nome da mesorregião 
CODMICRO: código da microrregião 



NOMEMICR: nome da microrregião 
CODUFMES: agregação dos códigos da UF com a mesorregião 
CODUFME1: agregação dos códigos da UF com a mesorregião e a microrregião 
AREA_97: área aferida em 1997 (em km2 , ao que tudo indica) 
LAT1: latitude de algum ponto dentro do município –em graus decimais 
LONG1: longitude desse ponto, em graus decimais 
LATITUDE: latitude de algum ponto dentro do município –em graus, minutos e 
segundos 
LONGITUD: longitude desse ponto, em graus, minutos e segundos 
DENSIDADE: em habitantes por m2, ao que tudo indica 

Se for aglutinar os municípios nas microrregiões a que pertencem: 

• Há de eliminar os dados que são exclusivos a cada município ou que não 
podem ser simplesmente agregados, por exemplo: 
SPRPERIMET, SPRROTULO, SPRNOME, CODMUNIC, COD, NOMEMUNI, LAT1*, 
LONG1*, LATITUDE*, LONGITUD* e DENSIDADE** 

• pode-se eliminar antes algumas redundâncias, ou pelos dados estarem 
repetidos ou por serem constantes para todo o Estado, por exemplo: 
CODUF, NOMEUF, SIGLAUF, REGIAO, CODUFMES, CODUFME1 

• alguns desses dados devem resultar constantes, por se aplicar a cada conjunto 
de municípios de uma daad microrregião, por exemplo:  

• e outros são constantes para cada microrregião, ou podem ser agregados de 
alguma forma, por exemplo: 
SPRAREA, POPULACA, POPHOMEM, POPMULHE, POPURBAN, POPRURAL : 
podem ser somados para cada microrregião; e 
CODMESO, NOMEMESO, CODMICRO, NOMEMICR : são constantes dentro de 
cada microrregião 

* as coordenadas de um ponto dentro da microrregião poderiam ser feitas para 
coincidir com as da sua sede. 
** a densidade poderia ser recalculada após a agregação das populações e 
áreas de cada microrregião. 

 



Selecionar do menu suspenso Vector > Geoprocesing Tools > Dissolve... 

Input Layer: SP_citiesG [EPSG:5527] 

Dissolve field(s):  CODMESO, NOMEMESO, CODMICRO, NOMEMICR – são 
valores constantes em cada microrregião. Os campos CODMICRO e NOMEMICR 
em conjunto serão os agregadores de fato das microrregiões. 

Dissolved: clique no botão […] navegue até a pasta desejada e indique um 
nome para o shapefile, por exemplo: SP_micro mapa das microrregiões 

Antes de executar: 

Se for executado, os demais dados, que se desejaria, como resultantes da soma 
de SPRAREA, POPULACA, POPHOMEM, POPMULHE, POPURBAN, POPRURAL de 
cada município seriam perdidos. 

Várias estratégias podem ser definidas para somar esses dados para cada 
microrregião em uma tabela a parte, a qual seria linkada ao mapa das 
microrregiões conforme se viu em exercício anterior. 

Dentre elas, a de exportar os dados tabulares para serem agregados em outro 
software, por exemplo, no MS-Access. E depois de agregados, serem 
importados novamente. 

[RUN] – para execcutar 

Pode observar que, as colunas da tabela de dados das microrregiões se 
conservam e que os valores para CODMESO, NOMEMESO, CODMICRO, 
NOMEMICR resultam corretos, mas não as demais. 

Há de se eliminar as colunas desnecessárias e apagar os dados errados das 
demais. 

Se o layer resultante no mapa aparecer com o nome Dissolved, altere o nome 
para o que havia sido escolhido antes. 

Salvar o projeto 

Agregar microrregiões em suas respectivas mesorregiões 

Idem, para as mesorregiões. 

 



Parte III - Intersecção 

 

Quais as classes de vegetação presentes em cada mesorregião de SP? 

Baixe e descompacte o arquivo: 

• SP_vegetation – polígonos de classes de vegetação do Estado de São Paulo 

 

Importar classes de vegetação de SP para o banco de dados 

Abrir o arquivo SP_vegetation.MIF com o Note Pad (Bloco de Notas), WordPad ou 
similar, tendo o cuidado de não associar arquivos MIF ao aplicativo usado (caso 
contrário o Windows irá acreditar que arquivo MIF se abre com tal aplicativo). 

No cabeçalho do arquivo, seu metadados, encontra-se o trecho que define o sistema 
de projeção: 

CoordSys Earth Projection 27, 92, Meters, -5.400000e+001, 

0.000000e+000, 0.000000e+000, 0.000000e+000, 0.000000e+000 

Bounds (92247.00000, -2813519.000000) (1004247.00000, -

2192519.000000) 

Pode-se buscar qual o sistema de coordenadas no texto “The MapInfo Interchange File 
(MIF) Format Specification” no arquivo Mapinfo_Mif.pdf 
Sob o item tipos e formatos de dados: 
na página da disciplina Tidia > Repositório > Links & outros materiais de interesse: 

Na página 20 indica-se que o “Projection 27” do cabeçalho corresponde à projeção do 
tipo “Polyconic” e na página 26 vê-se que “92” corresponde ao já conhecido Datum 
SAD69. 

Também que, conforme o disposto na página 4, o Meridiano Central da projeção é -
5.400000e+001 em notação científica, ou seja, -54o ou 54 o W (corresponde à interface 
entre os fusos 21 e 22 da Carta do Brasil ao Milionésimo) – ver nos slides sobre 
sistemas de coordenadas, visto em aula. 

E, que, a origem das coordenadas (LON,LAT) = (0,0) é o encontro desse meridiano com 
o Equador. As coordenadas estão em metros e o mapa se insere num “quadrilátero” 
de pouco mais de 92 km ao Norte do Equador até uns 2 milhões e 800 mil km ao Sul do 
Equador e; de aproximadamente 1 milhão de km a Leste do Meridiano Central (54 o W) 
até uns 2 milhões e duzentos mil km a Oeste. 



Crie novo Projeto para carregar o SP_vegetation, por causa do seu sistema de 
coordenadas ser diferente do SP_cities. 

Após carregar SP_vegetation.MIF(/MID) verifique qual o sistema atribuído a ele e ao 
Projeto, em decorrência disso, que deve ser algo como: 

USER:100028 -  * Generated CRS (+proj=poly +lat_0=0 +lon_0=-54 +x_0=0 
+y_0=0 +ellps=aust_SA +towgs84=-57,1,-41,0,0,0,0 +units=m +no_defs) 

Seguindo a boa prática, exporte o mapa para shapefile e substitua no novo Projeto, o 
antigo em MIF/MID pelo novo, por exemplo, de nome SP_vegetacao (sem acentaução 
ou cedilha), mantendo-se o mesmo sistema de coordenadas. 

Agregar polígonos segundo a classe de vegetação 

Para reduzir a complexidade das operações de Intersecção, os diversos polígonos de 
cada tipo de vegetação serão agregados num único multipolígono, o que pode ser 
obtido com o Dissolve, descrito no passo anterior, mas não antes de ser indexado 
espacialmente. 

Usar como atributo de agregação o SPRCLASSE 

Observar que os valores das colunas SPRAREA e SPRPERIMET estão errados, a exemplo 
do que se viu no item II deste exercício. 

Remover o arquivo anterior do Projeto. 

Indexar espacialmente o arquivo resultante, de nome SP_vegetacaoM, por exemplo. 

Observar que há onze classes definidas e, ao se fazer sua seleção na tabela de dados, 
por apontamento, mais de um polígono correspondente é indicado no mapa. 



Ou alterar a legenda de modo a colorir segundo a classe de vegetação 

Determinar quais classes de vegetação estão presentes em quais mesorregiões 

Para obter tal resultado, há de se efetuar a interseção espacial entre os mapas das 
mesorregiões e das classes de vegetação. 

A boa prática também recomenda ter ambos ao mesmo sistema de coordenadas. A 
vantagem de trabalhar com um sistema de projeção é de se poder mais tarde calcular 
áreas a partir do mapa resultante. A desvantagem, neste caso, estaria nesta projeção 
ser dada por uma transformação, de SAD69 para WGS84 em sua definição, portanto já 
se apresentar como um cálculo. 

Pode-se testar ambas abordagens para verificar o resultado, lembrando de indexar o 
shapefiles envolvidos na operação antes de fazêla. 

Exemplo para SP_meso convertido para a projeção policônica do mapa da vegetação e 
indexado espacialmente: 

Vector > Intersection 

Input layer: SP_mesoP [User: 100028] 
Overlay layer: SP_vegetacaoM [User: 100028] 
Input fields to keep: CODMESO e NOMEMESO 
Overlay fields to keep: SPRCLASSE 
Intersection: […] Create New File… sp_vegetacao_meso 
[ Run ] 

e… 

Feature (5) has invalid geometry. Please fix the geometry or change the 

Processing setting to the "Ignore invalid input features" option. 

Execution failed after 0.27 seconds 

Observe na região Sul do mapa das mesorregiões que há falhas que 

possivelmente esteja atrapalhando o processamento. 

 

Pode-se verificar também a qualidade dos dados vetoriais do SP_vegetacaoM com 

Vector > Geometry Tools > Check Validity... 

E descobrir que, dos 10 elementos passam, e outros dois estão com problemas. 

 


