
Exercício 3 – com QGIS 3 

 

Criar Plano a partir de tabela de coordenadas de pontos. Realizar operação geográfica 
(Coletar). Colorir mapa com base em valores de tabelas (Legenda). 

Anexar tabelas com as cardinalidades de relacionamento (1:1) e (N:1) a planos de 
informações. 

Controlar a exibição das tabelas associadas a um Plano de informações. 

Baixar e descompactar os arquivos abaixo: 

• homicides2002.csv – ocorrências de homicídos no Município de São Paulo em 
2002 – em formato CSV 

• SOC_ECONOMY. csv – dados sócio-econômicos dos distritos do Município de 
São Paulo – em formato CSV 

• HOSPITALS. csv – hospitais nos distritos do Município de São Paulo – em 
formato CSV 

 

Abrir o projeto QGIS, salvo no exercício anterior e  

e exibir apenas os distritos 

[   ] CPTM 
[   ] MetroSP 
[ √ ] Distritos 

I - Importar tabela de homicídios (pontos) 

Antes de tentar carregar os dados no QGIS, há de se tentar saber do seu conteúdo. O 
arquivo formato CSV é do tipo texto e, portanto, pode ser lido com Notepad (Bloco de 
Notas), WordPad, por exemplo. 

Observe que os dados estão organizados em colunas, separadas por ponto e vírgula 

( ; ). A primeira linha indica os nomes dessas colunas: ID, LOC_X e LOC_Y. 

A coluna ID identifica cada ocorrência e deve ter sido gerada automaticamente quando 
da entrada de dados de ocorrências de homicídios. Se houverem outras tabelas com 
informações mais detalhadas sobre cada homicídio essa seria a coluna de ligação com 
elas. 

Observe que as coordenadas, dadas por LOC_X e LOC_Y, em projeção UTM, têm suas 

partes fracionárias separadas da inteira por um ponto ( . ) e não por uma vírgula ( , ). 

 



Layer > Add Layer > Add Delimited text layer... 

 File name: clique no botão [...] e selecione homicides2002.csv 

 Layer name: deve ter sido preenchido automaticamente como homicides2002 

 Encoding: Windows-1252 (ou system), mas neste caso não importa, por não 
haver texto com acentuação 

 File Format 

  ( • ) Custom delimiters: [ √ ] Semicolon 

 Record and Fields Options 

  Number of header lines to discard: 0 

  [ √ ] First Record has Field names – 1ª linha são os nomes dos campos 

  [ √ ] Detect field types – para associar os tipos de dados a partir dos 
dados 

  [   ] Decimal separator is comma – o separador é na verdade o ponto ( . ) 

  [   ] Trim fields – caso houvesse texto com espaço(s) em branco antes ou 
depois dele 

  [   ] Discard empty fields 

 Geometry Definition 

  ( • ) Point coordinates – pelas colunas LOC_X e LOC_Y difinirem 
coordenadas 

   X field: LOC_X 

   Y field: LOC_Y 

   [   ] DMS coordinates – coordenadas estã em metros 

   Geometry CRS: EPSG: 5533 – SAD69(96) / UTM zone 23S 

 

 [ Add ] – para executar, depois [ Close ] 

 

 

O layer foi criado, mas, a exemplo do exercício anterior, há de se criar o shapefile 
correspondente, o qual passa a ser o arquivo a ser referenciado e objeto de futuro 
processamento – a contagem dos casos de homicídio por distrito. 

 

[ √ ] homicides2002  Properties... > information ... 

 Indica que o layer corresponde ao arquivo csv 

 



Crie, e inclua no mapa, o shapefile homicides2002 a partir desse layer e, depois, 
remova o layer associado ao csv desse mapa. 

Verifique que o layer das ocorrências de homicídios do mapa seja o shapefile ( e não o 
csv) 

Salve o projeto para atualizar seus mapas. 

 

Determinar número de homicídios em cada Distrito 

Aplicar a contagem visual seria não tirar proveito dos recursos contemporâneos 
disponibilizados pelo software SIG. Além de tedioso está sujeito a erros e omissões. 

Vector > Analysis Tools > Count Points in Polygon... 

Polygons: Distritos [EPSG:5533] 

Points: homicides2002 [EPSG:5533] 

Weigt field [optional]: permite somar os valores de alguma coluna, ao invés da 
simples contagem – não é o caso (não pode ser usado em conjunto com Class 
Field) 

Class Field [optional]: permite usar uma das colunas como qualificador, caso em 
que apenas se registra haver ou não haver pontos para cada valor dessa coluna 
(não pode ser usado em conjunto com Weight Field) – também não é o caso 

Count field name: casos 

Count: clique no botão [...] selecione Save To File e indique a pasta e o nome, 
para criar o shapefile com a contagem de homicídios, a partir dos distritos, 
p.ex., Distritos_contagem_homicidios 

[ Run ] – para executar e... 

Aparece a mensagem: 

Feature (17) has invalid geometry. Please fix the geometry or change the 

Processing setting to the "Ignore invalid input features" option. 

Execution failed after 0.49 seconds 



Trata-se de erro geométrico nos distritos! 

Há duas alternativas: 
(0) configurar a operação do Processing para ignorar o erro (!?) 
(1) buscar em software SIG as ferramentas necessárias para sua correção; ou 
(2) buscar outra fonte de dados de distritos – o que se faz nos próximos passos. 

Novo mapa de distritos – opção (2) acima 

Busque e baixe o arquivo DistrRMSP.zip , na página da disciplina no Tidia, em seu 
Repositório: 

Em Notas de Aula e exercícios: > dados da RMSP para exercícios >  
O link: Distritos da RMSP - Córrego Alegre - UTM 23S (Centro de Estudos da 
Metrópole), sob os anos 2005 – 2011 

O arquivo Zip contém o shapefile com distritos, não apenas do município de São Paulo, 
mas de toda sua Região Metropolitana – CEMdist.shp (e shx, dbf, prj, etc.). O 
CEMdist.prj indica que o sistema de coordenadas é Córrego Alegre / UTM 23S. 

Carregue os novos distritos sob os atuais. 

Verifique em CEMDist  Properties > Source, que o sistema de coordenadas foi 
interpretado corretamente – EPSG:22523 – Corrego Alegre 1970-72 / UTM zone 23S 

Observe o encoding definido, como windows-1252 (ou system) 

Verifique em CEMDist  Open Attribute Table , se, na coluna NOME, a acentuação nos 
nomes dos arquivos esteja correta, pois a configuração do system pode não ser 
equivalente ao codepage Windows-1252. 

Antes de se proceder a contagem dos casos de homicídios há de se observar que tais 
dados limitam-se ao município de São Paulo, e não a toda sua Região Metropolitana. E 
que, para tal contagem, é recomendável que os elementos dos dois arquivos 
correspondentes aos dois layers estejam referenciados ao mesmo sistema de 
coordenadas. 

Para selecionar apenas os distritos do município de São Paulo, faça uma consulta por 
atributos, com MUNNOME = ‘SAO PAULO’ (sem o acento, como se vê na coluna de 
dados correspondente). 

Mas antes, desmarque o layer [   ] Distritos – dos distritos com erros na geometria. 

Experimente a opção Select Features by Value do conjunto de ícones de seleção 
do menu suspenso. 

MUNNOME: SAO PAULO 
[ Select features ] 
e [Close] 



Depois salve os selecionados em novo shapefile, p.ex., CEMdistMSP, tendo o cuidado 
de redefinir o sistema de coordenadas para [EPSG:5533] - SAD 69(96) / UTM zone 23S, 
a mesma dos demais arquivos mostrados como layers no mapa. 

Remova o layer dos distritos da RMSP e Salve o Projeto. 

 

Determinar número de homicídios em cada Distrito - II 

Antes de executar, há de se criar indexação espacial para os novos distritos. 

Em CEMDistMSP  Properties > Source clique no botão [Create Spatial Index] 

Sem indexação especial o QGIS pode levar um tempo inexplicável para realizar 
a operação de consulta espacial. 

Vector > Analysis Tools > Count Points in Polygon... 

Polygons: CEMdistMSP [EPSG:5533] 

Points: homicides2002 [EPSG:5533] 

Weigt field [optional]: permite somar os valores de alguma coluna, ao invés da 
simples contagem – não é o caso (não pode ser usado em conjunto com Class 
Field) 

Class Field [optional]: permite usar uma das colunas como qualificador, caso em 
que apenas se registra haver ou não haver pontos para cada valor dessa coluna 
(não pode ser usado em conjunto com Weight Field) – também não é o caso 

Count field name: casos 

Count: clique no botão [...] selecione Save To File e indique a pasta e o nome, 
para criar o shapefile com a contagem de homicídios, a partir dos distritos, 
p.ex., CEMdistMSP_contagem_homicidios 

[ Run ] – para executar e... 

A operação cria uma cópia dos distritos com uma coluna adicional com a contagem dos 
casos de homicídio. 

Na lista de layers, o novo layer aparece como Count e pode ser mudado para 
CEMdistMSP_contagem_homicidios. O arquivo gerado na pasta indicada está 
com o nome esperado. 

Assim como foi feito no exercício anterior, podem-se visualizar estatísticas de intervalo 
para a contagem de cada distrito e também exportar uma tabela com essas 
informações. 



Pode-se desmarcar o layer homicides2002, pois seus dados foram agregados e 
incorporados aos distritos. 

 

Salve o projeto para atualizar seus mapas. 

 

Colorir distritos com base no número de homicídios 

CEMdistMSP_contagem_homicidios  Properties > Symbology 

Alterar, do default, Single symbol para Graduated 

Column: casos 

Column ramp: o gradiente vermelho parece adequado 

Mode: Equal Interval 

Classes: 9 (ou seja ~ S 96) 

[ OK ] 

 

Visualizar a mapa de distritos com maiores indicadores de violência 

( i ) Ferramenta Identify Features 

visualizar a mapa de distritos – distritos com maiores números 

 GRAJAU: 284 

 JARDIM ANGELA: 201 

 JARDIM SAO LUIS: 193 

 

Desfazer a Legenda 

CEMdistMSP_contagem_homicidios  Properties > Symbology 

Alterar novamente de Graduated, para Single symbol 

Se necessário, ajuste a Cor de preenchimento dos polígonos 

 

  



II - Importar tabela com relação de cardinalidade 1:1 – SOC_ECONOMY 

 

Antes de prosseguir, desmarque [   ] os layers CEMdistMSP e 
CEMdistMSP_contagem_homicidios. 

E marque o layer [ √ ] Distritos – usado no exercício anterior. 

 

Da mesma forma como feito no item I deste exercício, antes de tentar carregar os 
dados no QGIS, há de se tentar saber do seu conteúdo. O arquivo formato CSV é do 
tipo texto e, portanto, pode ser lido com Notepad (Bloco de Notas), WordPad, por 
exemplo.  

 

Layer > Add Layer > Add Delimited text layer... 

 File name: clique no botão [...] e selecione SOC_ECONOMY.csv 

 Layer name: deve ter sido preenchido automaticamente como SOC_ECONOMY 

 Encoding: Windows-1252, mas observe, em Layer Settings > Sample Data, que o 
único campo com texto é o DENO e não está acentuado. 

 File Format 

  ( • ) Custom delimiters: [ √ ] Semicolon 

 Record and Fields Options 

  Number of header lines to discard: 0 

  [ √ ] First Record has Field names – 1ª linha são os nomes dos campos 

  [ √ ] Detect field types – para associar os tipos de dados a partir dos 
dados 

  [   ] Decimal separator is comma – o separador é na verdade o ponto ( . ) 

  [   ] Trim fields – caso houvesse texto com espaço(s) em branco antes ou 
depois dele 

  [   ] Discard empty fields 

 Geometry Definition 

  ( • ) No geometry (attribute only table) – por não conter coordenadas, 
as associações entre os dados sócio-econômicos com os distritos será feita com base 
nos valores das colunas ID ou DENO. 

 

 [ Add ] – para executar, depois [ Close ] 

 

A tabela SOC_ECONOMY é listada na lista de layers, mas não no mapa, por não estar 
neste momento associada a qualquer dado espacial. 



Pode-se visualizar seu conteúdo com SOC_ECONOMY  Open Attribute Table 

 

Ligar a tabela SOC_ECONOMY ao mapa de distritos 

 

Em Distritos   Properties > Joins 

Clicar no botão [ + ] para definir a ligação 

Join layer: SOC_ECONOMY 

Join Field: ID (mas poderia ser também DENO) 

Target field: ID (mas poderia ser também DENO) 

[ √ ] Cache join layer in virtual memory 

[   ] Dynamic form – apenas se estiver editando dados e quiser que uma 
alteração no valor do campo ID de um Distrito se reflita automaticamente no 
correspondente valor do campo ID da tabela SOC_ECONOMY a ele ligado 

[   ] Editable join layer – apenas se deve marcar se for alterar valores dos 
campos da tabela resultado da ligação entre a que acompanha o layer Distritos 
e a SOC_ECONOMY a ele ligado 

[√ ] Joined Fields – marcar para selecionar os campos a serem mostrados, da 
tabela SOC_ECONOMY, como associados aos distritos correspondentes, por 
exemplo: RENDA_FAM, ANOS_EST, IDADE_MED e TAXA_CRESC 

[√ ] Custom Field Name Prefix – marcar e alterar o default SOC_ECONOMY_ 
para apenas SC_ 

 

[ OK ] 

Deve aparecer a ligação recém criada como Join layer SOC_ECONOMY na lista, a qual 
pode ser Editada ou Removida quando desejado (veja botões Edit Selected Join e 

Remove Selected Join [ - ]. 

 

Importante: usar os botões [ Apply ] e [ OK ] antes de fechar a janela Properties > 
Joins, caso contrário o que foi definido, conforme acima indicado, nãos será 
executado. 

 

Em Distritos  Open Attribute Table pode-se visualizar dados da tabela 
SOC_ECONOMY associados a cada distrito, para cada um dos 96 distritos. 

 

Salve o projeto para atualizar seus mapas e joins. 

 

  



III - Importar tabela com relação de cardinalidade N : 1 - HOSPITALS 

 

Assim como nos dois casos anteriores, antes de tentar carregar os dados no QGIS, há 
de se tentar saber do seu conteúdo. O arquivo formato CSV é do tipo texto e, portanto, 
pode ser lido com Notepad (Bloco de Notas), WordPad, por exemplo.  

 

Trata-se de tabela de hospitais e se espera que possa haver mais de um hospital 
associado a muitos dos distritos, não apenas um. Também poderá haver distritos sem 
hospital cadastrado na tabela. 

Carregue a tabela HOSPITALS.csv, como layer de texto delimitado, da mesma forma 
que feito no item II deste exercício. 

Verifique na tabela que há 371 registros de hospitais listados. 

 

Ligar a tabela HOSPITALS ao mapa de distritos 

 

Em Distritos   Properties > Joins 

Clicar no botão [ + ] para definir a nova ligação 

Join layer: HOSPITALS 

Join Field: DISTRITO 

Target field: DENO 

[ √ ] Cache join layer in virtual memory 

[   ] Dynamic 

[   ] Editable join  

[√ ] Joined Fields – marcar para selecionar os campos a serem mostrados, da 
tabela HOSPITALS, como associados aos distritos correspondentes, por 
exemplo: HOSPITAL e NUM_LEITOS 

[√ ] Custom Field Name Prefix – marcar e alterar o default HOSPITALS_ para 
apenas H_ 

 

[ OK ] 

Deve aparecer a ligação recém criada como Join layer HOSPITALS na lista, a qual 
pode ser Editada ou Removida quando desejado (veja botões Edit Selected Join 

e Remove Selected Join [ - ]. 

Importante: usar os botões [ Apply ] e [ OK ] antes de fechar a janela Properties 
> Joins, caso contrário o que foi definido, conforme acima indicado, nãos será 
executado. 

 



Em Distritos  Open Attribute Table pode-se visualizar que: 

• no caso de distritos sem hospitais cadastrados (BRASILANDIA, CURSINO, 
MANDAQUI, e ARICANDUVA) os campos H_HOSPITAL e H_LEITOS estão como 
NULL, ou seja ausência do dado, o que está correto. 

• apenas um dos hospitais e seus leitos está associado a cada distrito com ao 
menos um hospital, o que não está correto. 

Remova esta ligação, por não exibir o resultado correto. 

 

Em Project > Project Properties... selecione Relations e clique no botão 

[ + Add Relation ] 

Name: Distritos-Hospitais 

Referenced layer (Parent): Distritos (lado um da cardinalidade um para muitos) 

Referenced Field: DENO 

Referncing layer (Child): HOSPITALS (lado muitos da cardinalidade um para 
muitos) 

Referencing Field: DISTRITO 

Relationship strength: Association (default) 

 Composition 

Não se esquecer de salvar o que foi definido com [ Apply ] e [ OK ] antes de 
fechar a janela. 

 

Em Distritos  Open Attribute Table e, no canto inferior direito indique que se deseja 
visualizar cada distrito num FORMULÁRIO (switch to form view) e não numa tabela 
(switch to table view). 

 

Na lista da esquerda altere o campo dos distritos cujos valores se deseja ver para 
DENO (nome dos distritos). Observar que a parte esquerda da janela mostra os demais 
dados do distrito selecionado e, logo abaixo, a lista de hospitais associados a cada um. 

Para visualizar os dados desses hospitais indique, no canto superior direito da relação 
Distritos-Hospitais que se deseja visualizá-los numa TABELA (switch to table view) e 
não num formulário (switch to form view). 

 

Salve o projeto para atualizar seus mapas, joins e relations. 

 

A Figura 4 exibe um Modelo Conceitual, segundo a notação da Modelagem de Objetos 
e Relacionamentos – MOR de Embley (1998). Nele os distritos do MSP estão 
associados a um número de variáveis socioeconômicas com seus valores, indicadas de 
forma genérica, e não explícita, uma a uma. Também a um certo número de 



homicídios. Os dados socioeconômicos e de homicídios estão associados ao ano de sua 
ocorrência/levantamento. Os distritos também estão associados a hospitais e estes, a 
dados, como, por exemplo, o número de leitos. 

Figura 4 – Modelo Conceitual do Domínio do Exercício 3 

 

É possível agregar dados da tabela de hospitais de forma a indicar o total de leitos de 
cada Distrito? 

Com a tabela de atributos dos distritos aberta, clique no botão Field Calculator (seu 
ícone se parece com um ábaco). 

[√ ] Create a new Field 

[√ ] Create a virtual Field – para que os valores sejam recalculados 
dinamicamente (sem gerar nova coluna de tabela do mapa) – a definição do 
campo fica armazenada no Project. 

Output Field name: TOT_LEITOS 

Output Field type: Whole number (integer) 

Expression: 

Na lista da direita, selecionar Aggregates > relation_aggregate e construir a 
expressão no quadro da esquerda conforme o exemplo, no que resulta: 

relation_aggregate('Distritos-Hospitais','sum',"NUM_LEITOS") 

Distrito
MSP

0..0..

0..0..

1..1..

0..0..

1..1..

Hospital

0..0..

leitos

11

ano

homicidios

valor

varável 
socioeconomica

11

1..1..

0..0..

11



O resultado para cada Distrito aperece nas duas formas de visualização, 
formulário e tabela. 

Salve o projeto para atualizar seus mapas, joins, relations e campos virtuais. 

Faça o mesmo para gerar: 

• contagem de hospitais cadastrados em cada Distrito 

• contagens diferenciadas para hospitais públicos e privados cadastrados 

• número de leitos diferenciados para hospitais públicos e privados cadastrados 

  



Respostas: 

 

• número de leitos diferenciados para hospitais públicos e privados cadastrados 

relation_aggregate('Distritos-Hospitais','sum',if("PUBLICO"='S',"NUM_LEITOS",0)) 


